Flash Player 10.1 for PowerPC Mac

Adobe Flash
v 10.1
Requires G3+ , OS X 10.4 / 10.5 

If you really REALLY need to use flash on your PowerPC Mac for some reason here is the last available flash update for Tiger / Leopard.

Also check [ This ] post to see how to make Flash version 11.5 work.

No comments: